Web Shield: driver not found

Assistance with AVG Internet Security and AVG Internet Security Home Edition

Moderator: Moderators

Web Shield: driver not found

Postby burnfast81 » Sun May 04, 2008 3:52 pm

I have Windows Vista and when I 1st installed AVG on my computer the installation asked me to upgrade my version which I did. Installation was successful without any problems that I'm aware of. But when I looked in my taskbar I noticed the exclamation point displaying. I knew it was AVG so I opened up the user interface and the firewall, e-mail scanner, and webshield components are not properly running and I can't figure out why it is. See image below as it will show you what I am seeing.

Image

I have the latest version of AVG Internet Security and even though I'm still using it as a trial version I thought e-mailing AVG would help me to resolve this problem, but I haven't heard anything from them and I've e-mailed them twice now within a 2 week period.

Could someone please help me so I can get this running? I've tried uninstalling it, but something like the blue screen of death (BSOD) appeared the 1st time. Except the error message mentioned something about a memory error and if the problem persist to run my system utility program and to contact my system or network administrator.

When I tried it the 2nd time, it appeared it was successfully uninstalled except for my Internet quit working and after it fully finished uninstalling it gave me this error message:

Code: Select all
Local machine: installed successfully
    Installation:
        Warning: Action failed for file avgfwfd.inf: file unregistration....
            AVG Firewall NDIS driver installation failed.
                Avg text message exception.


I had to reinstall the program just so I can get back online. After I installed it for the 2nd time I did notice the error message:

Code: Select all
Local machine: installed successfully
    Installation:
        Warning: Action failed for file avgemc.exe: enabling in Windows Firewall....
            Error 0x80004003
        Warning: Action failed for file avgnsx.exe: enabling in Windows Firewall....
            Error 0x80004003


Please I hope someone can help me. I'm at a complete lost as to what to do and it doesn't appear AVG is going to respond.

I thank you all for helping me.
burnfast81
AVG Wannabee
 
Posts: 7
Joined: Sun May 04, 2008 3:28 pm

Advertisement

Postby sc123 » Sun May 04, 2008 4:00 pm

First of all, the exclamation point will appear if the firewall is disabled. It just thinks something is wrong even if you manually disabled it.

Second, I have never seen the Web Shield error. I don't recommend using the Web Shield at this time due to other issues, so simply re-install AVG in custom mode and make sure you uncheck Web Shield.

Let us know how it goes!
Regards,
SC123 - Founder, http://www.AVGForums.com
-------------------------------------------------------
Complete uninstall/reinstall method | Other tools to try | Search the forums!
User avatar
sc123
Forum Administrator
 
Posts: 2095
Joined: Tue Jul 24, 2007 3:50 pm
Location: Virginia, USA

Postby burnfast81 » Sun May 04, 2008 4:09 pm

sc123 wrote:First of all, the exclamation point will appear if the firewall is disabled. It just thinks something is wrong even if you manually disabled it.

Second, I have never seen the Web Shield error. I don't recommend using the Web Shield at this time due to other issues, so simply re-install AVG in custom mode and make sure you uncheck Web Shield.

Let us know how it goes!


Well in that case I think I'd rather uninstall it the right way without getting that BSOD and having my internet not work. Unless anyone knows how I can fix my internet after I am successfully able to uninstall it.

I'll go to another competitor.
burnfast81
AVG Wannabee
 
Posts: 7
Joined: Sun May 04, 2008 3:28 pm

Postby sc123 » Sun May 04, 2008 4:14 pm

burnfast81 wrote:Well in that case I think I'd rather uninstall it the right way without getting that BSOD and having my internet not work. Unless anyone knows how I can fix my internet after I am successfully able to uninstall it.

I'll go to another competitor.


Just uninstall it then re-install in custom mode making sure not to install the Firewall or Web Shield components.
Regards,
SC123 - Founder, http://www.AVGForums.com
-------------------------------------------------------
Complete uninstall/reinstall method | Other tools to try | Search the forums!
User avatar
sc123
Forum Administrator
 
Posts: 2095
Joined: Tue Jul 24, 2007 3:50 pm
Location: Virginia, USA

Postby burnfast81 » Sun May 04, 2008 6:05 pm

sc123 wrote:
burnfast81 wrote:Well in that case I think I'd rather uninstall it the right way without getting that BSOD and having my internet not work. Unless anyone knows how I can fix my internet after I am successfully able to uninstall it.

I'll go to another competitor.


Just uninstall it then re-install in custom mode making sure not to install the Firewall or Web Shield components.


Well now I did what you said and my Internet is not working for Windows Vista. Fortunately I was able to get online going into the other OS I have installed on this computer - Ubuntu.

So how do I get my Internet working????
burnfast81
AVG Wannabee
 
Posts: 7
Joined: Sun May 04, 2008 3:28 pm

Postby sc123 » Sun May 04, 2008 6:52 pm

I'm going to need to know more about your problem to assist you.

First, please verify in the AVG Control Panel (System Overview) that Firewall is not present, nor should be Web Shield.

Second, check Network Connections to see if your network card is connected, or what it says.

Third, see if Windows Firewall is enabled. Start>Control Panel>Windows Firewall.
Regards,
SC123 - Founder, http://www.AVGForums.com
-------------------------------------------------------
Complete uninstall/reinstall method | Other tools to try | Search the forums!
User avatar
sc123
Forum Administrator
 
Posts: 2095
Joined: Tue Jul 24, 2007 3:50 pm
Location: Virginia, USA

Postby burnfast81 » Sun May 04, 2008 7:23 pm

sc123 wrote:I'm going to need to know more about your problem to assist you.

First, please verify in the AVG Control Panel (System Overview) that Firewall is not present, nor should be Web Shield.

Second, check Network Connections to see if your network card is connected, or what it says.

Third, see if Windows Firewall is enabled. Start>Control Panel>Windows Firewall.


Neither firewall or web shield are present. I have a modem that connects into my ethernet card and it mentions IPv4 and IPv6 is not enabled and the firewall is enabled.
burnfast81
AVG Wannabee
 
Posts: 7
Joined: Sun May 04, 2008 3:28 pm

Postby sc123 » Sun May 04, 2008 7:29 pm

Does your network card say it's connected? Make sure IPv4 is enabled, and you should be able to leave IPv6 disabled. I would also disable the Windows Firewall just to see if that's the problem.
Regards,
SC123 - Founder, http://www.AVGForums.com
-------------------------------------------------------
Complete uninstall/reinstall method | Other tools to try | Search the forums!
User avatar
sc123
Forum Administrator
 
Posts: 2095
Joined: Tue Jul 24, 2007 3:50 pm
Location: Virginia, USA

Postby burnfast81 » Sun May 04, 2008 7:57 pm

sc123 wrote:Does your network card say it's connected? Make sure IPv4 is enabled, and you should be able to leave IPv6 disabled. I would also disable the Windows Firewall just to see if that's the problem.


Network card says it is not connected to a network, media state says enabled, but IPv4 & IPv6 says not connected. IPv4 is enabled and IPv6 is enabled, but its never been disabled before installing AVG the 1st time I think. I tried enabling and disabling Windows Firewall, no luck.
burnfast81
AVG Wannabee
 
Posts: 7
Joined: Sun May 04, 2008 3:28 pm

Postby sc123 » Sun May 04, 2008 10:18 pm

I'd disable IPv6, as it has been known to cause issues - even if it is unlikely that it's causing yours.

"Not connected" in Windows Vista usually means there is no DHCP server on the other end to give it an IP address. Do you need to set a static IPv4 address?
Regards,
SC123 - Founder, http://www.AVGForums.com
-------------------------------------------------------
Complete uninstall/reinstall method | Other tools to try | Search the forums!
User avatar
sc123
Forum Administrator
 
Posts: 2095
Joined: Tue Jul 24, 2007 3:50 pm
Location: Virginia, USA

Postby burnfast81 » Mon May 05, 2008 5:51 pm

sc123 wrote:I'd disable IPv6, as it has been known to cause issues - even if it is unlikely that it's causing yours.

"Not connected" in Windows Vista usually means there is no DHCP server on the other end to give it an IP address. Do you need to set a static IPv4 address?


Setting up a static IPv4 address isn't necessary.
burnfast81
AVG Wannabee
 
Posts: 7
Joined: Sun May 04, 2008 3:28 pm

Postby burnfast81 » Mon May 05, 2008 6:11 pm

I disabled IPv6 and happy to say I'm finally online in Windows Vista.

How come disabling IPv6 worked? I thought it was enabled before I installed AVG.

Thank you for your help!
burnfast81
AVG Wannabee
 
Posts: 7
Joined: Sun May 04, 2008 3:28 pm

Postby sc123 » Tue May 06, 2008 7:59 am

I'm glad that solved your problem :) IPv6 causes all kinds of bizarre issues with network equipment (routers, switches, modems, etc) that don't support it. Even some of those that do still conflict. It's just best to disable it since almost nothing uses it yet.
Regards,
SC123 - Founder, http://www.AVGForums.com
-------------------------------------------------------
Complete uninstall/reinstall method | Other tools to try | Search the forums!
User avatar
sc123
Forum Administrator
 
Posts: 2095
Joined: Tue Jul 24, 2007 3:50 pm
Location: Virginia, USA

Re: Web Shield: driver not found

Postby junker » Thu Sep 23, 2010 9:27 am

Hi i just got this error message during an installation:

Local machine: installation failed
Installation:
Error: Action failed for file avgfwfd.inf: file registration....
AVG Firewall NDIS driver installation failed.
Error 0x80070005: NDIS installation FAILED.

I was installing on XP Home SP3.

I got round it by turning off Windows Firewall the re-running the installtion prgram. Worked a treat. (one other thing - on the second installation I asked it not to install the AVG toolbar in Internet Explorer).
junker
AVG Wannabee
 
Posts: 1
Joined: Thu Sep 23, 2010 9:23 am

Re: Web Shield: driver not found

Postby stephanieg915 » Sat Dec 31, 2016 7:58 am

Allows observe..how many times do you think of your kitchen sinks constant supply disposal also known as the garbage disposal? I'm making reference to at night situations you have to discard the leftovers down the sink. Every dayonce weekly.once a monthonce a year possibly? I'd expect it is not that the moment each day because that might be creepy. Nicely, actually, should you be obtaining opinion of the continuous feed disposal more often than once per month, I'd think something is incorrect in the. Knowing why. Undoubtedly, some other household stuff like ones fridges, cookers, ranges, water heaters, and so on undoubtedly get our own concentration whenever they go out due to tariff of being forced to resolve or perhaps switch the home appliance. Nonetheless, yesterday I stumbled upon personally thinking considerably concerning the trash disposer during my destroy. Beginning yesterday, because i ended up being eliminating several food items via the disposal, Cleaning it once a to make on the disposal, however it by no means came upon. Today, We are usually not a carpenter or even a Do-It-Yourself'er. However, My spouse and i knew only enough for being risky. So, I guaranteed your disposal seemed to be turned off and i also put my hand around the disposal to it out as well as I could. That's some sort of disgusting instant I say to you. I tested the particular disposal plus it still would not come on. So, My partner and i referred to as my property manager and the man experienced their renovator stop by and ensure the gadget has been indeed damaged. I could truthfully not trust it when we received changed the machine about three times ago. I figured that having to exchange a new trash disposal twice inside 36 months would have been a bit significantly. I do not apply it greatly to be broken frequently. Consequently, My partner and i made the decision Hermes Birkin to discover a number of steady supply disposals personally.Wow, how electrifying, so? Yes, appropriate. Wasting valuable time trying to learn as well as know very well what could make an excellent constant nourish disposer. Surprisingly, a number of belongings you must take under consideration in advance of getting a trash disposal. You should be sure the rubbish disposer is actually stainless -- the main benefit of developing a metal home appliance articulates for itself. Confirm how the mincing chamber includes a glass-filled nylon that can help to avoid rust. It must be super easy to setup, nonetheless was uncertain the best way to verify that just before purchasing one. Last but not least, it must involve some kind of makers warranty and that is certainly essential at least it should be important to a person. So, built with the information over, My partner and i eventually left regarding Lowe's and acquired a continuous nourish disposal of which fulfilled all the required requirements. As well as, I recently mounted that myself personally. Is it possible to think that? I actually nevertheless are unable to even today, nevertheless, after i dump my areas swap for the disposal, the including tunes to my personal head. Not really, it's best to are aware that I used to be capable to undertake updating your disposer without any help. Plainly can do the item, you may too. You know what to search for within a disposal therefore find out more on steady feed disposals below and check out this yourself.
stephanieg915
AVG Know-A-Lot
 
Posts: 33
Joined: Fri Dec 30, 2016 4:06 am


Return to AVG Internet Security

Who is online

Users browsing this forum: No registered users and 1 guest

cron